Skip to main content

Install Layer SDK

The Layer SDK is a Python module distributed on pypi.

Layer SDK can be installed via pip. We recommend using virtual environments when installing with pip. For more information, refer to Creation of virtual environments.

note

Layer only supports Linux and macOS systems. If you are a Windows user, we recommend using Windows Subsystem for Linux (WSL).

Layer SDK might work if you run PowerShell as an Administrator, but Layer does not guarantee support for it.

Prerequisites

  • An internet connection
  • A Linux or macOS system to run the Layer SDK on
  • A Safari 12+ or Chrome 70+ web browser to run the Layer UI
  • Python version 3.7+ installed
  • Latest version of pip installed

Install Layer SDK

  1. Upgrade pip.
pip install --upgrade pip
  1. Install the Layer SDK.
pip install layer

If you have permission problems, then try:

pip install --user layer
note

You need to log in to Layer before running any Layer SDK commands. If you don't have a Layer account already, you can create one now for free.